Introduction to LabVIEW

GRAPhICAL PROGRAMMING FOR ENGINEERS AND SCIENTISTS

Robert Berger
Course Goals

• Become comfortable with the LabVIEW environment and data flow execution
• Ability to use LabVIEW to solve problems
• LabVIEW Concepts
  – Acquiring, saving and loading data
  – Find and use math and complex analysis functions
  – Work with data types, such as arrays and clusters
  – Displaying and printing results
The Virtual Instrumentation Approach
LabVIEW Graphical Development System

- Graphical Programming Environment
- Compile code for multiple OS and devices
- Useful in a broad range of applications
Virtual Instrumentation Applications

• Design
  – Signal and Image Processing
  – Embedded System Programming
    • (PC, DSP, FPGA, Microcontroller)
  – Simulation and Prototyping
  – And more…

• Control
  – Automatic Controls and Dynamic Systems
  – Mechatronics and Robotics
  – And more…

• Measurements
  – Circuits and Electronics
  – Measurements and Instrumentation
  – And more…
The NI Approach – Integrated Hardware Platforms

- High-Speed Digitizers
- High-Resolution Digitizers and DMMs
- Multifunction Data Acquisition
- Dynamic Signal Acquisition
- Instrument Control
- Digital I/O
- Counter/Timers
- Machine Vision
- Motion Control
- Distributed I/O and Embedded Control
- Signal Conditioning and Switching
- Unit Under Test

PXI Modular Instrumentation
Desktop PC
Laptop PC
PDA
Section I – LabVIEW Environment

A. Getting Data into your Computer
   • Data Acquisition Devices
     – NI-DAQ
     – Simulated Data Acquisition
     – Sound Card

B. LabVIEW Environment
   • Front Panel / Block Diagram
   • Toolbar / Tools Palette

C. Components of a LabVIEW Application
   • Creating a VI
   • Data Flow Execution

D. Additional Help
   • Finding Functions
   • Tips for Working in LabVIEW
A. Setting Up Your Hardware

- Data Acquisition Device (DAQ) [Track A]
  - Actual USB, PCI, or PXI Device
  - Configured in MAX

- Simulated Data Acquisition Device (DAQ) [Track B]
  - Software simulated at the driver level
  - Configured in MAX

- Sound Card [Track C]
  - Built into most computers
### What type of device should I use?

<table>
<thead>
<tr>
<th></th>
<th>Sound Card*</th>
<th>NI USB DAQ</th>
<th>NI PCI DAQ</th>
<th>Instruments*</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>AI Bandwidth</strong></td>
<td>8–44 KS/s</td>
<td>10–200 KS/s</td>
<td>250 K–1.2 Ms/s</td>
<td>20kS/s–2 GS/s</td>
</tr>
<tr>
<td><strong>Accuracy</strong></td>
<td>12–16 bit</td>
<td>12–16 bit</td>
<td>14–18 bit</td>
<td>12–24 bit</td>
</tr>
<tr>
<td><strong>Portable</strong></td>
<td>x</td>
<td>x</td>
<td>—</td>
<td>some</td>
</tr>
<tr>
<td><strong>AI Channels</strong></td>
<td>2</td>
<td>8–16</td>
<td>16–80</td>
<td>2</td>
</tr>
<tr>
<td><strong>AO Channels</strong></td>
<td>2</td>
<td>1–2</td>
<td>2–4</td>
<td>0</td>
</tr>
<tr>
<td><strong>AC or DC</strong></td>
<td>AC</td>
<td>AC/DC</td>
<td>AC/DC</td>
<td>AC/DC</td>
</tr>
<tr>
<td><strong>Triggering</strong></td>
<td>—</td>
<td>x</td>
<td>x</td>
<td>x</td>
</tr>
<tr>
<td><strong>Calibrated</strong></td>
<td>—</td>
<td>x</td>
<td>x</td>
<td>x</td>
</tr>
</tbody>
</table>

* The above table may not be representative of all device variations that exist in each category.
What is MAX?

- MAX stands for Measurement & Automation Explorer.
- MAX configures and organizes all your National Instruments DAQ, PCI/PXI instruments, GPIB, IMAQ, IVI, Motion, VISA, and VXI devices.
- Used for configuring and testing devices.

[Icon Found on Windows Desktop]

[Measurement & Automation]

[Devices and Interfaces - Measurement & Automation Explorer]

[Devices and Interfaces]

[What is Devices and Interfaces?]

-The Devices and Interfaces category lists installed and detected CAN, DAQ, FieldPoint Serial Controllers, GPIB, IMAQ, IVI, Motion, Serial, VISA, and VXI hardware.

-If you do not see your devices...
Exercise 1 – Setting Up Your Device

• Use Measurement and Automation Explorer (MAX) to:
  – Configure and test your Data Acquisition (DAQ) device
Exercise 1 – Setting Up Your Device

• Use Measurement and Automation Explorer (MAX) to:
  – Configure and test your Simulated Data Acquisition (DAQ) device
Exercise 1 – Setting Up Your Device

- Use Windows to:
  - Verify your Sound Card

Un-Mute Microphone
Open and Run LabVIEW
Start » All Programs » National Instruments LabVIEW 8.6

Startup Screen:

Start from a Blank VI:
New » Blank VI

Start from an Example:
Examples » Find Examples...

ni.com
LabVIEW Programs Are Called Virtual Instruments (VIs)

Each VI has 2 Windows

Front Panel
• User Interface (UI)
  – Controls = Inputs
  – Indicators = Outputs

Block Diagram
• Graphical Code
  – Data travels on wires from controls through functions to indicators
  – Blocks execute by Dataflow
Controls Palette
(Controls & Indicators)

(Place items on the Front Panel Window)

Control: Numeric

Indicator: Numeric Slide

Customize Palette View
Functions (and Structures) Palette

Structure:
While Loop

(Place items on the Block Diagram Window)
Status Toolbar

- Run Button
- Continuous Run Button
- Abort Execution

Additional Buttons on the Diagram Toolbar

- Execution Highlighting Button
- Retain Wire Values Button
- Step Function Buttons
Demonstration 1: Creating a VI

Front Panel Window

- Graph Indicator
- Boolean Control
- Input Terminals

Block Diagram Window

- Output Terminal
Dataflow Programming

- Block diagram execution
  - Dependent on the flow of data
  - Block diagram does NOT execute left to right
- Node executes when data is available to ALL input terminals
- Nodes supply data to all output terminals when done
Debugging Techniques

• Finding Errors
  Click on broken **Run** button. Window showing error appears.

• Execution Highlighting
  Click on **Execution Highlighting** button; data flow is animated using bubbles. Values are displayed on wires.

• Probes
  Right-click on wire to display probe and it shows data as it flows through wire segment.
  You can also select Probe tool from Tools palette and click on wire.
Exercise 2 – Acquiring a Signal with DAQ

- Use a LabVIEW template to:
  - Acquire a signal from your DAQ device

This exercise should take 15 minutes.
Exercise 2 – Acquiring a Signal with the Sound Card

• Use LabVIEW to:
  – Acquire a signal from your sound card

This exercise should take 15 minutes.
Context Help Window

• Help»Show Context Help, press the <Ctrl+H> keys
• Hover cursor over object to update window

Additional Help

– Right-Click on the VI icon and choose Help, or
– Choose “Detailed Help.” on the context help window

Extract Single Tone Information.vi

Time signal in
export signals
detected frequency
detected amplitude
detected phase (deg)
error in (no error)
advanced search
error out
measurement info

Takes a signal in, finds the single tone with the highest amplitude or searches a specified frequency range, and returns the single tone frequency, amplitude, and phase. The data type you wire to the time signal in input determines the polymorphic instance to use.

Detailed help
Tips for Working in LabVIEW

• Keystroke Shortcuts
  – <Ctrl+H> – Activate/Deactivate Context Help Window
  – <Ctrl+B> – Remove Broken Wires From Block Diagram
  – <Ctrl+E> – Toggle Between Front Panel and Block Diagram
  – <Ctrl+Z> – Undo (Also in Edit Menu)

• Tools»Options… – Set Preferences in LabVIEW

• VI Properties–Configure VI Appearance, Documentation, etc.
Section II – Elements of Typical Programs

A. Loops
   • While Loop
   • For Loop

B. Functions and SubVIs
   • Types of Functions
   • Creating Custom Functions (SubVI)
   • Functions Palette & Searching

C. Decision Making and File IO
   • Case Structure
   • Select (simple If statement)
   • File I/O
Loops

• While Loops
  – Terminal counts iteration
  – Always runs at least once
  – Runs until stop condition is met

• For Loops
  – Terminal counts iterations
  – Run according to input $N$ of count terminal $\mathbf{N}$
Drawing a Loop

1. Select the structure

2. Enclose code to be repeated

3. Drop or drag additional nodes and then wire
3 Types of Functions (from the Functions Palette)

Express VIs: interactive VIs with configurable dialog page (blue border)

Standard VIs: modularized VIs customized by wiring (customizable)

Functions: fundamental operating elements of LabVIEW; no front panel or block diagram (yellow)
What Types of Functions are Available?

• Input and Output
  – Signal and Data Simulation
  – Acquire and Generate Real Signals with DAQ
  – Instrument I/O Assistant (Serial & GPIB)
  – ActiveX for communication with other programs

• Analysis
  – Signal Processing
  – Statistics
  – Advanced Math and Formulas
  – Continuous Time Solver

• Storage
  – File I/O
Searching for Controls, VIs, and Functions

• Palettes are filled with hundreds of VIs
• Press the search button to index the all VIs for text searching
• Click and drag an item from the search window to the block diagram
• Double-click an item to open the owning palette
Create SubVI

• Enclose area to be converted into a subVI.
• Select **Edit»Create SubVI** from the Edit Menu.
LabVIEW Functions and SubVIs operate like Functions in other languages

**Function Pseudo Code**

```pseudo
def average (in1, in2, out)
    out = (in1 + in2)/2.0;
```

**Calling Program Pseudo Code**

```pseudo
def main
    average (in1, in2, pointavg)
```

**SubVI Block Diagram**

[Diagram of a SubVI block diagram with inputs in 1 and in 2, and output out, showing arithmetic operations and numbers 1.23, 2.0, and 1.23 indicating data flow and calculations.]

**Calling VI Block Diagram**

[Diagram of a calling VI block diagram with inputs in 1 and in 2, connected to a 2 pt Avg. function, and output pointavg, showing connections and data flow.]
Exercise 3.1 – Analysis

• Use LabVIEW Express VIs to:
  – Simulate a signal and display its amplitude and frequency

This exercise should take 15 minutes.
Exercise 3.2 – Analysis

• Use LabVIEW Express VIs to:
  – Acquire a signal and display its amplitude and frequency

This exercise should take 15 minutes.
Exercise 3.2 – Analysis

• Use LabVIEW Express VIs to:
  – Acquire a signal and display its amplitude and frequency

This exercise should take 15 minutes.
How Do I Make Decisions in LabVIEW?

1. Case Structures

   (a)

2. Select

   (c)
File I/O

File I/O – passing data to and from files
- Files can be binary, text, or spreadsheet
- Write/Read LabVIEW Measurements file (*.lvm)

Writing to LVM file

Reading from LVM file
Exercise 3.3 – Decision Making and Saving Data

• Use a case structure to:
  – Make a VI that saves data when a condition is met

This exercise should take 15 minutes.
File I/O Programming Model – Under the hood

1. Open/Create/Replace File
2. Read and/or Write to File
3. Close File
4. Check for Errors
Section III – Presenting your Results

A. Displaying Data on the Front Panel
   • Controls and Indicators
   • Graphs and Charts
   • Loop Timing

B. Signal Processing
   • MathScript
   • Arrays
   • Clusters
   • Waveforms
What Types of Controls and Indicators are Available?

- **Numeric Data**
  - Number input and display
  - Analog Sliders, Dials, and Gauges

- **Boolean Data**
  - Buttons and LEDs

- **Array & Matrix Data**
  - Numeric Display
  - Chart
  - Graph
  - XY Graph
  - Intensity Graph
  - 3D graph: point, surface, and model

- **Decorations**
  - Tab Control
  - Arrows

- **Other**
  - Strings and text boxes
  - Picture/Image Display
  - ActiveX Controls
Charts – Add 1 data point at a time with history

**Waveform chart** – special numeric indicator that can display a history of values

- Chart updates with each individual point it receives

**Functions** » **Express** » **Graph Indicators** » **Chart**
Graphs – Display many data points at once

**Waveform graph** – special numeric indicator that displays an array of data

- Graph updates after all points have been collected
- May be used in a loop if VI collects buffers of data

Functions ➔ Express ➔ Graph Indicators ➔ Graph
Building Arrays with Loops (Auto-Indexing)

- Loops can accumulate arrays at their boundaries with auto-indexing.
- For Loops auto-index by default.
- While Loops output only the final value by default.
- Right-click tunnel and enable/disable auto-indexing.

**Auto-Indexing Enabled**
- Wire becomes thicker
- 1D Array Indicator:
  - 1D Array
  - 0 1 2 3 4 5

**Auto-Indexing Disabled**
- Wire remains the same size
- Numeric Indicator:
  - Only one value (last iteration) is passed out of the loop
Creating an Array (Step 1 of 2)

From the Controls » Modern » Array, Matrix, and Cluster subpalette, select the Array icon.

Drop it on the Front Panel.
Create an Array (Step 2 of 2)

1. Place an Array Shell.
2. Insert datatype into the shell (i.e. Numeric Control).
How Do I Time a Loop?

1. Loop Time Delay
   • Configure the Time Delay Express VI for seconds to wait each iteration of the loop (works on For and While loops).

2. Timed Loops
   • Configure special timed While loop for desired $dt$. 

![Time Delay](image1)

![Timed Loop](image2)
Control & Indicator Properties

- Properties are characteristics or qualities about an object
- Properties can be found by right clicking on a Control or Indicator

Properties Include:
- Size
- Color
- Plot Style
- Plot color

Features include:
- Cursors
- Scaling
Exercise 4.1 – Manual Analysis

• Use the cursor legend on a graph to:
  – Verify your frequency and amplitude measurements

This exercise should take 15 minutes.
Textual Math in LabVIEW

• Integrate existing scripts with LabVIEW for faster development
• Interactive, easy-to-use, hands-on learning environment
• Develop algorithms, explore mathematical concepts, and analyze results using a single environment
• Freedom to choose the most effective syntax, whether graphical or textual within one VI

Supported Math Tools:
MathScript script node          MathSoft software
Mathematica software           MATLAB® software
Maple software                Xmath software
Math with the MathScript Node

- Implement equations and algorithms textually
- Input and Output variables created at the border
- Generally compatible with popular m-file script language
- Terminate statements with a semicolon to disable immediate output

Prototype your equations in the interactive MathScript Window.
The Interactive MathScript Window

- Rapidly develop and test algorithms
- Share Scripts and Variables with the Node
- View /Modify Variable content in 1D, 2D, and 3D

(RlabVIEW»Tools»MathScript Window)
Exercise 4.2 – Using MathScript

Use the MathScript Node and Interactive Window to process the acquired signal (logarithmic decay) in the MathScript and save the script.

This exercise should take 25 minutes.
Exercise 5 – Apply What You Have Learned

This exercise should take 20 minutes.
Section IV – Advanced Data Flow Topics (optional)

A. Additional Data types
   • Cluster

B. Data Flow Constructs
   • Shift Register
   • Local Variables

C. Large Application Development
   • Navigator Window
   • LabVIEW Projects
Introduction to Clusters

• Data structure that groups data together
• Data may be of different types
• Analogous to *struct* in C
• Elements must be either all controls or all indicators
• Thought of as wires bundled into a cable
• Order is important
Creating a Cluster

1. Select a Cluster shell.  
2. Place objects inside the shell.

Controls » Modern » Array, Matrix & Cluster
Cluster Functions

- In the **Cluster & Variant** subpalette of the **Programming** palette
- Can also be accessed by right-clicking the cluster terminal

(Terminal labels reflect data type)

**Bundle**

**Bundle By Name**

[Diagram of cluster functions and labels]
Using Arrays and Clusters with Graphs

The Waveform Datatype contains 3 pieces of data:
- \( t_0 = \) Start Time
- \( dt = \) Time between Samples
- \( Y = \) Array of \( Y \) magnitudes

Two ways to create a Waveform Cluster:

- Build Waveform (absolute time)
- Cluster (relative time)
Shift Register – Access Previous Loop Data

- Available at left or right border of loop structures
- Right-click the border and select **Add Shift Register**
- Right terminal stores data on completion of iteration
- Left terminal provides stored data at beginning of next iteration

![Diagram showing the use of Shift Register in a loop structure](image)
Local Variables

- Local Variables allow data to be passed between parallel loops.
- A single control or indicator can be read or written to from more than one location in the program
  - Local Variables break the dataflow paradigm and should be used sparingly
LabVIEW Navigation Window

- Shows the current region of view compared to entire Front Panel or Block Diagram
- Great for large programs

* Organize and reduce program visual size with subVIs
LabVIEW Project

• Group and organize VIs
• Hardware and I/O management
• Manage VIs for multiple targets
• Build libraries and executables
• Manage large LabVIEW applications
• Enable version tracking and management

(LabVIEW»Project»New)
Additional Resources

• NI Academic Web & Student Corner
  – http://www.ni.com/academic

• Connexions: Full LabVIEW Training Course
  – www.cnx.rice.edu
  – Or search for “LabVIEW basics”

• LabVIEW Certification
  – LabVIEW Fundamentals Exam (free on www.ni.com/academic)
  – Certified LabVIEW Associate Developer Exam (industry recognized certification)

• Get your own copy of LabVIEW Student Edition
  – www.ni.com/academic
The LabVIEW Certification Program

**Architect**
- Mastery of LabVIEW
- Expert in large application development
- Skilled in leading project teams

**Developer**
- Advanced LabVIEW knowledge and application development experience
- Project management skills

**Associate Developer**
- Proficiency in navigating LabVIEW environment
- Some application development experience

**Fundamentals Exam**
- Pre-Certification Skills Test
- Free On-Line Fundamentals Exam
Electronics Workbench and Multisim

- World’s most popular software for learning electronics
- 180,000 industrial and academic users
- Products include:
  - Multisim: Simulation and Capture
  - Multi-MCU: Microcontroller Simulation
  - MultiVHDL: VHDL Simulation
  - Ultiboard: PCB Layout
  - Electronics CBT: Computer-based training
- Low cost student editions available
- www.electronicsworkbench.com
Multisim Integrated with LabVIEW

1. Create Schematic

2. Virtual Breadboard

3. Simulate

4. PCB Layout

5. Test

6. Compare

ni.com
Your Next Step…

Take the free LabVIEW Fundamentals Exam at
ni.com/academic

Your first step to become LabVIEW Certified!